10/24/2014

Security Announcement - POODLE SSLv3 Vulnerability

Katie Smart's profile picture
Katie Smart Sr. Manager, Global Marketing Communications
Last week a security vulnerability known as POODLE was publicly announced that affects a relatively low number of Internet connected devices. However, this vulnerability is critical and could allow an attacker to read encrypted information, even when passed over an SSL connection. While not vulnerable, SightCall is taking this issue seriously by following the steps below. At the bottom of the article, we’ve listed steps you can take to help protect yourself. What we've done: What we will continue to do: What you should do: As always, if you have any questions about this notification or the security of your SightCall account, we encourage you to contact us at support@sightcall.com for additional assistance.

Next Up